summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2aa9560a85c5..9b3fda6f8bf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=k3s-git
-pkgver=r1.7d1baa9
-pkgrel=5
+pkgver=r1.f90cbed
+pkgrel=1
pkgdesc='Lightweight Kubernetes'
arch=(x86_64)
url='https://github.com/rancher/k3s'
license=(APACHE)
-makedepends=(docker git go)
+makedepends=(docker git go setconf)
pkgver() {
cd $pkgname
@@ -15,7 +15,8 @@ pkgver() {
}
prepare() {
- git clone --depth=1 "git://github.com/rancher/k3s" $pkgname 2>/dev/null || (cd $pkgname; git fetch origin; git reset --hard origin/master)
+ git clone --depth=1 "https://github.com/rancher/k3s" $pkgname 2>/dev/null || (cd $pkgname; git fetch origin; git reset --hard origin/master)
+ setconf "$pkgname/k3s.service" ExecStart '/usr/bin/k3s server'
}
build() {
@@ -26,6 +27,8 @@ package() {
install -Dm755 $pkgname/dist/artifacts/k3s "$pkgdir/usr/bin/k3s"
install -Dm755 $pkgname/dist/artifacts/hyperkube "$pkgdir/usr/bin/hyperkube"
install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 $pkgname/k3s.service "$pkgdir/usr/lib/systemd/system/k3s.service"
}
# vim: ts=2 sw=2 et:
+