summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 801852865328..258c2749ae7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,14 @@
# Maintainer: Nat Lasseter <aur at 4574 dot co dot uk>
pkgname="k40whisperer"
-pkgver="0.55"
+pkgver="0.56"
pkgrel="1"
pkgdesc="Control software for the stock K40 Laser controller"
arch=("any")
url="https://www.scorchworks.com/K40whisperer/k40whisperer.html"
license=("GPL")
-depends=("python" "python-lxml" "python-pyusb" "python-pillow" "tk")
-optdepends=("python-pyclipper")
+depends=("python" "python-lxml" "python-pyusb" "python-pillow" "python-pyclipper" "tk")
makedepends=("unzip" "dos2unix")
_pkgfile="K40_Whisperer-${pkgver}_src"
@@ -19,13 +18,11 @@ source=(
"https://www.scorchworks.com/K40whisperer/${_pkgfile}.zip"
"97-ctc-lasercutter.rules"
"${pkgname}.install"
- "k40_whisperer.py.patch"
)
sha256sums=(
- "1ef91a35e52c73ab699e5c9685b47e735bba3a53eef257a9eb4016ae7b77496d"
+ "7646a7610e99f2f9cb7e086c6a6813d1a5171cb0ea3e20d1f7c981bd513a3706"
"19b490100927a74a4db8c6332b8a995eb1d1dc24c31467c03e3d8ac62759b508"
"5d32866a044ce3239881eacd01720b95285031a003a79056644d30e728fcee19"
- "6f61cbd2d5ee32bd601965f7b56f2b42de5a152ec4a33a5949066220982e30c9"
)
install="${pkgname}.install"
@@ -33,7 +30,7 @@ install="${pkgname}.install"
build() {
cd ${_pkgfile}
dos2unix k40_whisperer.py
- patch k40_whisperer.py ../k40_whisperer.py.patch
+ sed -ri 's|Image.open\("(.+\.png)"\)|Image.open("/usr/lib/k40whisperer/\1")|' k40_whisperer.py
chmod +x k40_whisperer.py
}