summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 32 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfc846e697ac..4a121440aa3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,41 @@
-# Maintainer: Leonid Koftun <leonid.koftun@gmail.com>
+# Maintainer: Dirk Wilden <dirk.wilden@device-insight.com>
pkgname=kafkactl
-pkgver=1.15.1
+pkgver=1.17.0
pkgrel=1
-pkgdesc='Command Line Tool for managing Apache Kafka'
-arch=('i686' 'x86_64')
-url="https://github.com/deviceinsight/kafkactl"
-license=('Apache')
-makedepends=('go')
-depends=('glibc')
-source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('a648f0ae6fdc37cd14f6792c4899ae2e9cc5f126ee7bbd1884b77e07489d062a')
+pkgdesc="Command Line Tool for managing Apache Kafka"
+url="https://github.com/deviceinsight/kafkactl/"
+arch=("i686" "x86_64" "aarch64")
+license=("APACHE")
+depends=("glibc")
+makedepends=('go>=1.16')
+optdepends=('kubectl: for kafka running in Kubernetes cluster',
+'bash-completion: auto-completion for kafkactl in Bash',
+'zsh-completions: auto-completion for kafkactl in ZSH')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/deviceinsight/kafkactl/archive/v${pkgver}.tar.gz"
+)
+sha256sums=(
+ 8bef3d2570c220eabebb5a215d5551420a4ba0139ab25853d88134ea04a4fbd1
+)
build() {
- cd $pkgname-$pkgver
- go build \
- -ldflags "-extldflags $LDFLAGS" \
- -o $pkgname .
+ cd "${pkgname}-${pkgver}"
+ export CGO_LDFLAGS="$LDFLAGS"
+ go build -ldflags "-linkmode=external -X github.com/deviceinsight/kafkactl/cmd.Version=${pkgver}" -o ${pkgname} .
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ make test
}
package() {
- cd $pkgname-$pkgver
- install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ "${pkgdir}/usr/bin/${pkgname}" completion bash | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+ "${pkgdir}/usr/bin/${pkgname}" completion fish | install -Dm644 /dev/stdin "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
+ "${pkgdir}/usr/bin/${pkgname}" completion zsh | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
}