summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b5bd4b4102c..cf845b1f611f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
-# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
-# Contributor: Gokcehan Kara <gokcehankara@gmail.com>
-# Contributor: Guillaume ALAUX <Guillaume at ALAUX dot net>
-# Contributor: Shizeeg Unadequatov <shizeeque@gmail.com>
-
_ref=""
pkgname=kakoune-git
-pkgver=r5245.e73cd782
+pkgver=r5401.a61c51df
pkgrel=1
pkgdesc='Code editor heavily inspired by Vim'
arch=('i686' 'x86_64')
url='https://github.com/mawww/kakoune'
license=('custom:unlicense')
-depends=('ncurses' 'boost')
-optdepends=('xorg-xmessage: for nicer debugging messages'
- 'xdotool: add support for kak windows switching (in grep, make... files)'
- 'clang: add command for C/CPP insert mode completion support'
- 'universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition'
- 'tmux: tabbing support')
-makedepends=('git' 'asciidoc')
+depends=(
+ 'boost-libs'
+ 'ncurses'
+)
+optdepends=(
+ 'xorg-xmessage: for nicer debugging messages'
+ 'xdotool: add support for kak windows switching (in grep, make... files)'
+ 'clang: add command for C/CPP insert mode completion support'
+ 'universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition'
+ 'tmux: tabbing support'
+)
+makedepends=(
+ 'asciidoc'
+ 'boost'
+ 'git'
+)
source=("${pkgname}::git+https://github.com/mawww/kakoune.git${_ref}")
sha256sums=('SKIP')