summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd5bbd8cb931..2303ce8182e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Gokcehan Kara <gokcehankara@gmail.com>
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+# Contributor: Gokcehan Kara <gokcehankara@gmail.com>
# Contributor: Guillaume ALAUX <Guillaume at ALAUX dot net>
# Contributor: Shizeeg Unadequatov <shizeeque@gmail.com>
pkgname=kakoune-git
-pkgver=r4278.6faed96
+pkgver=r4446.650a989
pkgrel=1
pkgdesc='Code editor heavily inspired by Vim'
arch=('i686' 'x86_64')
@@ -13,7 +14,8 @@ depends=('ncurses' 'boost')
optdepends=('xorg-xmessage: for nicer debugging messages'
'xdotool: add support for kak windows switching (in grep, make... files)'
'clang: add command for C/CPP insert mode completion support'
- 'universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition')
+ 'universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition'
+ 'tmux: tabbing support')
makedepends=('git' 'asciidoc')
source=("${pkgname}::git+https://github.com/mawww/kakoune.git")
@@ -36,6 +38,6 @@ build() {
package() {
cd "${srcdir}/${pkgname}/src"
- debug=no make install DESTDIR="${pkgdir}" PREFIX=/usr
+ debug=no make install-strip DESTDIR="${pkgdir}" PREFIX=/usr
install -D ../UNLICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}