summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD41
1 files changed, 20 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e0b4ca5d1c0..4a82e15e1ba0 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: leonekmi <usingarchbtw@leonekmi.fr>
pkgname=karaokemugen-git
-pkgver=6.1.3.r086c8f9bd
-pkgrel=2
+pkgver=4.1.10.r3713.g52d7e60c7
+pkgrel=1
pkgdesc="Karaoke playlist manager/player app used in parties or events."
arch=('x86_64')
url="https://mugen.karaokes.moe/"
license=('MIT')
groups=()
-depends=('mpv' 'ffmpeg' 'postgresql>=13' 'electron')
-makedepends=('git' 'npm' 'typescript' 'yarn' 'nodejs>=18' 'python' 'jq')
+depends=('mpv' 'ffmpeg' 'postgresql' 'electron' 'patch')
+makedepends=('git' 'npm' 'typescript' 'yarn' 'nodejs')
optdepends=('sudo: for using karaokemugen-install script')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -16,9 +16,9 @@ replaces=()
backup=()
options=()
install=${pkgname%-git}.install
-source=('karaokemugen::git+https://gitlab.com/karaokemugen/karaokemugen-app.git#branch=master'
- 'karaokemugen-lib::git+https://gitlab.com/karaokemugen/lib.git'
- 'karaokemugen-avatars::git+https://gitlab.com/karaokemugen/medias/guest-avatars.git'
+source=("${pkgname%-git}::git+https://gitlab.com/karaokemugen/code/karaokemugen-app.git"
+ "${pkgname%-git}-lib::git+https://gitlab.com/karaokemugen/code/lib.git"
+ "${pkgname%-git}-guests::git+https://gitlab.com/karaokemugen/medias/guest-avatars.git"
'install.sh'
'run.sh'
'icon256.png'
@@ -27,45 +27,43 @@ noextract=()
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'e31ff0dc6707adce89c3221a7c9c3cb6'
+ '74e8c0755a6e07cceb2895cef518660b'
'55557823030b7824a85a55469e119cb4'
'5e9a33a42fef7572b7e0fa504c586f32'
- '10561eed906a5efeed427f90501b4f49')
+ 'fae5d3e631e9ec8391655b31f586b74b')
# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.
pkgver() {
cd "$srcdir/${pkgname%-git}"
- echo "$(jq -r .version package.json | sed -e 's/-master//g').r$(git rev-parse --short origin/master)"
+ # Git, tags available
+ git describe --long --tags | sed -e 's/^v//' -e 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/${pkgname%-git}"
git submodule init
- git config submodule.src/lib.url $srcdir/${pkgname%-git}-lib
- git config submodule.assets/guestAvatars.url $srcdir/${pkgname%-git}-avatars
- git -c protocol.file.allow=always submodule update
+ git config submodule.src/lib.url "$srcdir/${pkgname%-git}-lib"
+ git config submodule.assets/guestAvatars.url "$srcdir/${pkgname%-git}-guests"
+ git submodule update
}
build() {
cd "$srcdir/${pkgname%-git}"
-
# Prepare dependencies
export HOME="$srcdir/$pkgname-home"
export XDG_CACHE_HOME="$srcdir/$pkgname-cache"
export npm_config_devdir="$srcdir/$pkgname-npm-dev"
export npm_config_cache="$srcdir/$pkgname-npm-cache"
- mkdir -p $HOME $XDG_CACHE_HOME $npm_config_devdir $npm_config_cache
- yarn install --frozen-lockfile
- yarn add --dev electron-builder
- yarn installkmfrontend
+ yarn setup
+
# Build and package with electron-builder
export NODE_ENV='production'
+ electronDist=$(dirname $(realpath $(which electron)))
electronVer=$(electron --version | tail -c +2)
- yarn build
- yarn buildkmfrontend
- yarn electron-builder --linux --x64 -c.electronDist=/usr/lib/electron -c.electronVersion=$electronVer --dir
+
+ yarn packer
}
package() {
@@ -74,6 +72,7 @@ package() {
# Application itself
install -dm755 "$pkgdir/usr/lib/${pkgname%-git}"
cp -dr --no-preserve=ownership packages/linux-unpacked/resources/* "$pkgdir/usr/lib/${pkgname%-git}/"
+ install -dm 755 "$pkgdir/usr/lib/${pkgname%-git}/asar"
chmod -R 755 "$pkgdir/usr/lib/${pkgname%-git}/"
# License