summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25fd746bbf96..b187c6ce09bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tmplt <tmplt@dragons.rocks>
pkgname=katriawm
-pkgver=20.08
+pkgver=20.09
pkgrel=1
pkgdesc="non-reparenting, dynamic window manager for X11 with decorations"
arch=("i686" "x86_64")
@@ -10,20 +10,14 @@ url="https://www.uninformativ.de/git/katriawm/file/README.html"
license=("MIT")
makedepends=("git")
depends=("libx11" "libxft" "libxrandr")
-source=("git+https://www.uninformativ.de/git/katriawm.git#tag=v${pkgver}"
- "set_prefix.patch")
-sha256sums=('SKIP'
- 'a9de73fa43affa7c32d0f678c21eb30aa9173d9e51eb8e170a0389db82f3bf8c')
+source=("git+https://www.uninformativ.de/git/katriawm.git#tag=v${pkgver}")
+sha256sums=('SKIP')
prepare() {
cd "${pkgname}/src"
- # Set prefix
- patch -Np2 -i "${srcdir}/set_prefix.patch"
-
# Read custom config headers from $XDG_CONFIG_HOME/katria{wm,bi}-config.h
-
config=${XDG_CONFIG_HOME:-~/.config/}
if [[ -f "${config}/katriawm-config.h" ]]; then
@@ -39,12 +33,12 @@ prepare() {
build() {
cd "${pkgname}/src"
- make
+ make prefix=/usr
}
package() {
cd "${pkgname}/src"
- make DESTDIR=${pkgdir} install
+ make prefix=/usr DESTDIR=${pkgdir} install
install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 ../README "${pkgdir}/usr/share/doc/${pkgname}/README"
}