summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d71bcc67a31a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=kbs2-bin
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="A secret manager backed by age"
+arch=('x86_64')
+url="https://github.com/woodruffw/kbs2"
+license=('MIT')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
+provides=("${pkgname%-bin}")
+source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}-linux-v${pkgver}.tar.gz")
+sha256sums_x86_64=('b69b9b8740ab64d9af77b93aedd749270f19d73cf4683d5b8f649e6792605c3d')
+
+package() {
+ install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-bin}"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
+}