summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74e6a5dbfe01..5bff9d2facf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,17 +10,17 @@ arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
depends=(kwidgetsaddons-git kconfig-git)
-makedepends=(git extra-cmake-modules-git qt5-tools clang python-pyqt5 doxygen sip4)
+makedepends=(git extra-cmake-modules-git qt6-tools clang python-pyqt6 doxygen sip4)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-optdepends=('python-pyqt5: for the Python bindings')
-groups=(kf5-git)
+optdepends=('python-pyqt6: for the Python bindings')
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}