summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e60c5ee042b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Leo sk <sk.griffinix@gmail.com>
+pkgname=kde-rounded-corners
+pkgver=1.0
+pkgrel=1.0
+pkgdesc="Round the corners of windows"
+arch=('x86_64')
+url="https://github.com/matinlotfali/KDE-Rounded-Corners"
+license=('GPL3')
+depends=(kwin)
+makedepends=(extra-cmake-modules cmake qt5-tools kinit git)
+source=(git+https://github.com/matinlotfali/KDE-Rounded-Corners)
+sha256sums=('SKIP')
+
+prepare() {
+ mkdir -p qt5build
+}
+
+build() {
+ cd qt5build
+ cmake ../KDE-Rounded-Corners/ -DCMAKE_INSTALL_PREFIX=/usr -DQT5BUILD=ON
+ make
+}
+
+package() {
+ cd qt5build
+ make DESTDIR="$pkgdir" install
+}