summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49f6e761080c..96eb8c4a1cb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_module=libs
pkgname=kde2-kde${_module}-git
-pkgver=2.2.2.r23941.b87a75db2
+pkgver=2.2.2.r24019.1e989a6f0
pkgrel=1
pkgdesc="Historical copy of the $_module module of KDE 2, adapted to compile on modern systems"
arch=(i686 x86_64)
-url="https://github.com/sandsmark/kde${_module}"
+url="https://invent.kde.org/sandsmark/kde2-${_module}"
license=("GPL2")
groups=(kde2)
depends=(qt2 audiofile libxslt python libtool hicolor-icon-theme)
@@ -16,13 +16,12 @@ provides=(kde2-kde${_module})
conflicts=(kde2-kde${_module} plasma-workspace)
options+=(libtool)
-# Mirror
-source=("git+https://github.com/sandsmark/kde${_module}.git")
+source=("git+https://invent.kde.org/sandsmark/kde2-kde${_module}.git")
md5sums=('SKIP')
pkgver() {
- cd kde${_module}
+ cd kde2-kde${_module}
printf "2.2.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -36,13 +35,13 @@ prepare() {
build() {
cd build
- cmake "$srcdir"/kde${_module} -DCMAKE_INSTALL_PREFIX=/usr -DKDEDIR=/usr/
+ cmake "$srcdir"/kde2-kde${_module} -DCMAKE_INSTALL_PREFIX=/usr -DKDEDIR=/usr/
make
}
package() {
cd build
make DESTDIR="$pkgdir/" install
- cd "$srcdir"/kde${_module}
+ cd "$srcdir"/kde2-kde${_module}
install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}