summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD96
1 files changed, 96 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0e9fe959275
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# $Id: PKGBUILD 253960 2015-12-08 15:40:43Z allan $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=kdebase-workspace
+_pkgname=kde-workspace
+pkgver=4.11.22
+_pkgver=15.08.0
+pkgrel=4
+pkgdesc="Provides the interface and basic tools for the KDE workspace"
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/kde/kde-workspace'
+license=('GPL' 'LGPL' 'FDL')
+# note on libxdamage:
+# not detected by namcap because libgl depends on it
+# but nvidia providing libgl does not depend on libxdamage
+depends=('kdebase-runtime' 'kdepimlibs4' 'lm_sensors' 'libraw1394'
+ 'qimageblitz' 'polkit-kde' 'xorg-xprop' 'libxdamage' 'libqalculate'
+ 'libxklavier' 'xorg-xsetroot' 'libxcomposite' 'libxinerama'
+ 'xorg-xrdb' 'libxres' 'xorg-xrandr' 'xorg-xmessage' 'libusb-compat'
+ 'kde-base-artwork' 'xcb-util-renderutil' 'xcb-util-image' 'ttf-font'
+ 'xcb-util-keysyms' 'xcb-util-wm' 'pciutils' 'glu')
+makedepends=('cmake' 'automoc4' 'boost' 'kdebindings-python2' 'networkmanager')
+optdepends=('kde-wallpapers: wallpapers for KDE Plasma Workspaces'
+ 'appmenu-qt: menu applications over dbus' 'kdepim4-runtime: to display events in the calendar')
+install="${pkgname}.install"
+backup=('usr/share/config/kdm/kdmrc' 'etc/pam.d/kde' 'etc/pam.d/kde-np' 'etc/pam.d/kscreensaver')
+source=("http://download.kde.org/stable/applications/${_pkgver}/src/${_pkgname}-${pkgver}.tar.xz"
+ 'kde.pam' 'kde-np.pam' 'kscreensaver.pam' 'kdm.service' 'kdm.logrotate'
+ 'etc-scripts.patch' 'terminate-server.patch' 'kdm-xinitrd.patch'
+ 'khotkeys-qt4.patch' 'dbus-update-environment.patch')
+sha1sums=('f08fbe309ed16c51ad31b0b260b2adeb7af1bb37'
+ '660eae40a707d2711d8d7f32a93214865506b795'
+ '6aeecc9e0e221f0515c6bf544f9a3c11cb6961fe'
+ 'c6afdf8964b2b2c4809b2e8e694729b2661e29df'
+ 'b6f8e8692737b11eec1f8022ce74b5b23e247b1b'
+ 'bbe55f2000217474ce7246f12ee437ceaaf7e9ae'
+ 'c079ebd157c836ba996190f0d2bcea1a7828d02c'
+ 'ac7bc292c865bc1ab8c02e6341aa7aeaf1a3eeee'
+ 'd509dac592bd8b310df27991b208c95b6d907514'
+ 'aa9d2e5a69986c4c3d47829721ea99edb473be12'
+ '410311314b1ccb1ed5607dcf8bd418074d8c4019')
+
+prepare() {
+ mkdir build
+
+ cd ${_pkgname}-${pkgver}
+
+ # reads the shell scripts in /etc/kde/
+ patch -p0 -i "${srcdir}"/etc-scripts.patch
+ # sends env vars to existing dbus
+ patch -p1 -i "${srcdir}"/dbus-update-environment.patch
+ # FS#26120
+ patch -p1 -i "${srcdir}"/kdm-xinitrd.patch
+ # FS#39188
+ patch -p1 -i "${srcdir}"/khotkeys-qt4.patch
+
+ # KDEBUG#202629
+ patch -p0 -i "${srcdir}"/terminate-server.patch
+}
+
+build() {
+ cd build
+ cmake ../${_pkgname}-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE4_BUILD_TESTS=OFF \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_Xmms=OFF \
+ -DWITH_libgps=OFF \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DWITH_CkConnector=OFF \
+ -DWITH_NepomukCore=OFF \
+ -DWITH_Soprano=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 "${srcdir}"/kde.pam "${pkgdir}"/etc/pam.d/kde
+ install -D -m644 "${srcdir}"/kde-np.pam "${pkgdir}"/etc/pam.d/kde-np
+ install -D -m644 "${srcdir}"/kscreensaver.pam "${pkgdir}"/etc/pam.d/kscreensaver
+
+ install -d -m755 "${pkgdir}"/usr/share/xsessions/
+ ln -sf /usr/share/apps/kdm/sessions/kde-plasma{,-safe}.desktop \
+ "${pkgdir}"/usr/share/xsessions/
+ install -d -m755 "${pkgdir}"/etc/kde/{env,shutdown}
+
+ install -d -g 135 -o 135 "${pkgdir}"/var/lib/kdm
+ install -D -m644 "${srcdir}"/kdm.service \
+ "${pkgdir}"/usr/lib/systemd/system/kdm.service
+ install -Dm644 "${srcdir}"/kdm.logrotate "${pkgdir}"/etc/logrotate.d/kdm
+}