summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 186bea60c4de..8a67f05b8fcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,20 @@
# Contributor: Stefano Avallone <stavallo@gmail.com>
pkgname=kdeplasma-addons-git
-pkgver=5.22.80_r8520.ga6435e48c
+pkgver=5.27.80_r9560.g2f8bb12e3
pkgrel=1
pkgdesc='All kind of addons to improve your Plasma experience'
arch=($CARCH)
url='https://kde.org/plasma-desktop/'
license=(LGPL)
depends=(plasma-workspace-git)
-makedepends=(git extra-cmake-modules-git kross-git qt5-webengine)
+makedepends=(git extra-cmake-modules-git kross-git qt6-webengine)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
optdepends=('kross-git: comic applet'
'purpose-git: Quickshare applet'
'quota-tools: disk quota applet'
- 'qt5-webengine: dictionary and webbrowser applets')
+ 'qt6-webengine: dictionary and webbrowser applets')
groups=(plasma-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
@@ -30,6 +30,7 @@ pkgver() {
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DCMAKE_INSTALL_LIBEXECDIR=lib \
-DBUILD_TESTING=OFF
cmake --build build