summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea507aeb67f5..b724e4dd8417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=kdocker
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="An application to help you dock any application into the system tray"
arch=('i686' 'x86_64')
url="https://github.com/user-none/KDocker"
@@ -12,8 +12,12 @@ sha256sums=('711c3a07d36d278eca47fa56db34fcb0f20f30210d9a1e86a9d0243b834e357a')
build() {
cd "$srcdir/KDocker-$pkgver"
+ # Fix building with Qt 5.5
sed -i '/<QCoreApplication>/ a\#include <QDataStream>' 3rdparty/qtsingleapplication/src/qtlocalpeer.cpp
+ # Make sure to restore docked applications on exit
+ sed -i '/delete m_trayItemManager;/ i\m_trayItemManager->undockAll();' src/kdocker.cpp
+
qmake-qt5
make
}