summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 302af9212fa2..eab5cee68553 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: Davide Depau <davide@depau.eu>
# Contributor: liberodark
+# Contributor: daniel666
pkgname=keeper-password-manager
-pkgver=14.5.1
+pkgver=14.9.8
pkgrel=1
-pkgdesc="Keeper is the world's #1 most downloaded password keeper and secure digital vault for protecting and managing your passwords."
+pkgdesc="Keeper is the world's #1 most downloaded password keeper and secure digital
+ vault for protecting and managing your passwords and other secret information."
arch=('x86_64')
url="https://keepersecurity.com"
license=('Custom')
depends=('xdg-utils')
-source_x86_64=("https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_${pkgver}_amd64.deb")
-source=($pkgname.desktop
- $pkgname.png)
-sha512sums=('2f342f212fca342211adf90e633d557f8619b6737e3652cbb5f6f01e2875d22cf2799b21447e9bef4b3ef81d85407b8ee41937e5b10d577a8d8139813f36f941'
- '03db6ce057c53dacb4f242c131f4f5f599a4b79aa834a9555aa58216084f25c1bd5850968b7a80a5887dec23103df84694f3bbd0718e8fe49d0152f86a1ddc5d')
-sha512sums_x86_64=('d881c45c8e5d90b65231db212a18b25c8f74befaa1e08f5aa4420ae48d6f7e4e7f7a9416e546851b365babe9fa1eaf5b52d01fa6c03fbf910b5577ac199a7308')
+source=("https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_${pkgver}_amd64.deb")
+sha512sums=('ec7a392c256cb122731a3fd97bb965419aef018004ab339ea298b9ca4035a6e50d4308d5e74c29073f0a539b6b528542f7be6408e646392dfe887d632804b2ef')
package() {
cd $srcdir
tar xpvf data.tar.xz
cp -r usr $pkgdir
- install -vDm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
- install -vDm644 $srcdir/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ msg2 "Setting needed '4755' mode to file: chrome-sandbox."
+ chmod 4755 $pkgdir/usr/lib/keeperpasswordmanager/chrome-sandbox
}