summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c6b4d6693c0..af1914fb3abc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
# Contributor: liberodark
pkgname=keeper-password-manager
-pkgver=14.9.9
+pkgver=14.9.10
pkgrel=1
pkgdesc="Keeper is the world's #1 most downloaded password keeper and secure digital
vault for protecting and managing your passwords and other secret information."
arch=('x86_64')
url="https://keepersecurity.com"
license=('Custom')
-depends=('xdg-utils')
+depends=('libsecret' 'nss' 'libxss' 'gtk3')
source=("https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_${pkgver}_amd64.deb"
'LICENSE')
-sha512sums=('60437f858e3f6332870cd2ea979ede137847a5e62971858cae97d0d786344e7852c6c115d91ef3509fe5cfdea5bdbb90f27106fddc60dbdeb5369ab602891038'
+sha512sums=('359fdd89b5ca4b4d7bbdf48df4d37dea0c960f6dc8db7da24290b3b0cb56f8a12228c0256be181948730cd127126278dbf91feb838c28e9480da62ecd748ab0e'
'9bd161a552aba146ee89ab930b8a444442d3cb4bba8cf5e94d1a04bfe2c99fae8372d0d04d5b01fe489578429e9fd020cb567e005b1a267fcb51a0bc4cb2f7b2')
-package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+package() {
+ bsdtar -xf "$srcdir"/data.tar.xz -C "$pkgdir"
+
+ echo "Setting needed '4755' mode to file: chrome-sandbox."
+ chmod 4755 "$pkgdir"/usr/lib/keeperpasswordmanager/chrome-sandbox
- cd "$srcdir"
- tar xpvf data.tar.xz
- cp -r usr "$pkgdir"
- msg2 "Setting needed '4755' mode to file: chrome-sandbox."
- chmod 4755 "$pkgdir/usr/lib/keeperpasswordmanager/chrome-sandbox"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 "$pkgdir"/usr/lib/keeperpasswordmanager/LICENSES.chromium.html "$pkgdir"/usr/share/licenses/chromium/LICENSES.chromium.html
}