summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd7f6919c456..7c6b4d6693c0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,17 @@ arch=('x86_64')
url="https://keepersecurity.com"
license=('Custom')
depends=('xdg-utils')
-source=("https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_${pkgver}_amd64.deb")
-sha512sums=('60437f858e3f6332870cd2ea979ede137847a5e62971858cae97d0d786344e7852c6c115d91ef3509fe5cfdea5bdbb90f27106fddc60dbdeb5369ab602891038')
+source=("https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_${pkgver}_amd64.deb"
+ 'LICENSE')
+sha512sums=('60437f858e3f6332870cd2ea979ede137847a5e62971858cae97d0d786344e7852c6c115d91ef3509fe5cfdea5bdbb90f27106fddc60dbdeb5369ab602891038'
+ '9bd161a552aba146ee89ab930b8a444442d3cb4bba8cf5e94d1a04bfe2c99fae8372d0d04d5b01fe489578429e9fd020cb567e005b1a267fcb51a0bc4cb2f7b2')
package() {
- cd $srcdir
- tar xpvf data.tar.xz
- cp -r usr $pkgdir
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd "$srcdir"
+ tar xpvf data.tar.xz
+ cp -r usr "$pkgdir"
msg2 "Setting needed '4755' mode to file: chrome-sandbox."
- chmod 4755 $pkgdir/usr/lib/keeperpasswordmanager/chrome-sandbox
+ chmod 4755 "$pkgdir/usr/lib/keeperpasswordmanager/chrome-sandbox"
}