summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15d4e8af13df..e0859e5197cf 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=keeper-password-manager
pkgver=16.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Keeper is the world's #1 most downloaded password keeper and secure digital
vault for protecting and managing your passwords and other secret information."
arch=('x86_64')
@@ -19,7 +19,12 @@ package() {
echo "Setting needed '4755' mode to file: chrome-sandbox."
chmod 4755 "$pkgdir"/usr/lib/keeperpasswordmanager/chrome-sandbox
-
+ echo "Setting needed '755' mode on directories: resources/*, locales, swiftshader"
+ find "$pkgdir"/usr/lib/keeperpasswordmanager/resources -type d -print0 | xargs -0 chmod 755
+ chmod 755 "$pkgdir"/usr/lib/keeperpasswordmanager/locales/
+ chmod 755 "$pkgdir"/usr/lib/keeperpasswordmanager/swiftshader/
+
+
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -Dm644 "$pkgdir"/usr/lib/keeperpasswordmanager/LICENSES.chromium.html "$pkgdir"/usr/share/licenses/chromium/LICENSES.chromium.html
}