summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99263568a75d..b795ed4611fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: surefire@cryptomile.net
pkgname=keeweb
-pkgver=1.18.5
-_electron=electron
+pkgver=1.18.6
+_electron=electron12
pkgrel=1
pkgdesc="Desktop password manager compatible with KeePass databases"
arch=('any')
@@ -24,11 +24,13 @@ source=(
"${pkgname}::git+https://github.com/keeweb/keeweb.git#tag=v${pkgver}"
"git+https://github.com/keeweb/keeweb-native-modules.git#tag=0.11.7"
'package.json.patch.js'
+ '67e917af3dcd9d78273774e7061f74d893b5523b.patch'
)
sha1sums=('SKIP'
'SKIP'
- '5e2a12694cf56ec9ed558554819dba0187e7fbdc')
+ '5e2a12694cf56ec9ed558554819dba0187e7fbdc'
+ '3b6341f657421899d4e4078b799bece7d93587e5')
case "$CARCH" in
i686) _arch=ia32;;
@@ -81,6 +83,9 @@ build() {
npm install --ignore-scripts
+ # https://github.com/antelle/keyboard-auto-type/commit/67e917af3dcd9d78273774e7061f74d893b5523b
+ patch -Np1 <"${srcdir}/67e917af3dcd9d78273774e7061f74d893b5523b.patch"
+
HOME="${srcdir}/.electron-gyp" \
npx electron-rebuild --arch="${_arch}" --version="$(</usr/lib/${_electron}/version)" --only=argon2,keytar,usb-detection,yubikey-chalresp,keyboard-auto-type
}