summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b90a4705ce0a..67231de4cd0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,40 @@
# Maintainer: zoe <chp321@gmail.com>
pkgname=kfoldersync
-_pkgname=KFolderSync
-_id1=1485353737
-_id2=8884ea838cec6b64d8bc75d8ac73ae82
-_id3=1526499274
-_id4=338265
+#_pkgname=KFolderSync
+#_id1=1485353737
+#_id2=8884ea838cec6b64d8bc75d8ac73ae82
+#_id3=1526499274
+#_id4=338265
pkgver=3.4.1
-pkgrel=5
+pkgrel=1
pkgdesc="Folder synchronization and backup tool for KDE"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://www.linux-apps.com/content/show.php/${_pkgname}?content=164092"
license=('GPLv2')
depends=('plasma-workspace' 'hicolor-icon-theme' 'kconfigwidgets' 'kdbusaddons' 'kitemviews' 'kwindowsystem' 'kxmlgui')
-makedepends=('extra-cmake-modules' 'phonon-qt5-gstreamer')
-source=("https://dl.opendesktop.org/api/files/downloadfile/id/$_id1/s/$_id2/t/$_id3/u/$_id4/${pkgname}-${pkgver}.tar.xz"
+#makedepends=('extra-cmake-modules' 'phonon-qt5-gstreamer')
+#source=("https://dl.opendesktop.org/api/files/downloadfile/id/$_id1/s/$_id2/t/$_id3/u/$_id4/${pkgname}-${pkgver}.tar.xz"
+source=("https://download.opensuse.org/repositories/home:/Vindex17:/myapps/Arch_Linux/x86_64/${pkgname}-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz"
"${pkgname}.install")
install=${pkgname}.install
-md5sums=('33e049d7065cb27382eb7bcb6432b41b' '262fc1597fb332894d1367f510a7f39b')
+md5sums=('172eb772746af84e12e6f976f9beb419' '262fc1597fb332894d1367f510a7f39b')
build()
{
-cd ${srcdir}/${pkgname}-${pkgver}
-mkdir build
-cd build
-cmake -DCMAKE_INSTALL_PREFIX=`qtpaths --install-prefix` -DCMAKE_BUILD_TYPE=Release ..
-make -j`nproc`
+#cd ${srcdir}/${pkgname}-${pkgver}
+#mkdir build
+#cd build
+#cmake -DCMAKE_INSTALL_PREFIX=`qtpaths --install-prefix` -DCMAKE_BUILD_TYPE=Release ..
+#make -j`nproc`
+ cd ${srcdir}
+ rm "../${pkgname}-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz"
}
package()
{
-cd "${srcdir}/${pkgname}-${pkgver}/build"
-make DESTDIR="${pkgdir}" install
+#cd "${srcdir}/${pkgname}-${pkgver}/build"
+#make DESTDIR="${pkgdir}" install
+ cd ${srcdir}
+ mv usr/ ${pkgdir}/
}