summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13d7cf3791c0..71ff3020cb00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Rachel Mant <dx-mon@users.sourceforge.net>
pkgname=kicad-nightly
-pkgver=5.99.0_4084_gb9f1601418
+pkgver=5.99.0_4092_g1ee3df61c9
pkgrel=1
pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad-pcb.org/'
license=('GPL')
-depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
-makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
-optdepends=(
- 'kicad-library: for footprints and symbols'
- 'kicad-library-3d: for 3d models of components'
+depends=(
+ 'wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade'
+ 'python-wxpython' 'kicad-library-nightly'
)
+makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
+optdepends=('kicad-library-3d-nightly: for 3d models of components')
source=(
- 'git+https://gitlab.com/kicad/code/kicad.git'#commit=b9f1601418
- 'git+https://gitlab.com/kicad/code/kicad-i18n.git'#commit=636831f
+ 'git+https://gitlab.com/kicad/code/kicad.git'#commit=1ee3df61c9
+ 'git+https://gitlab.com/kicad/code/kicad-i18n.git'#commit=72653a3
'kicad-nightly.env'
)
sha256sums=(
@@ -23,12 +23,6 @@ sha256sums=(
'fce26af6b9c181a99197bfc9bc6c778561ad55a375480f4d0d73bb34078b5d18'
)
-pkgver()
-{
- cd "$srcdir/kicad"
- git describe --tags | sed -e 's/-/_/g'
-}
-
build()
{
cd "$srcdir/kicad"