summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6205746a157e..bd4eb5061107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,18 @@ pkgdesc="Official KiCad release candidates and dev snapshots"
arch=('any')
url="http://kicad-pcb.org/"
license=('GPL3')
-# glm 0.9.9.3 breaks the build
-depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'wxpython' 'opencascade' 'ngspice>=27' 'kicad-footprints' 'kicad-symbols' 'kicad-packages3d')
+depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'python-wxpython' 'opencascade' 'ngspice>=27' 'kicad-footprints' 'kicad-symbols' 'kicad-packages3d')
makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost')
optdepends=('kicad-symbols' 'kicad-packages3d' 'kicad-footprints' 'kicad-templates')
conflicts=('kicad' 'kicad-git' 'kicad-scripting-git' 'kicad-bzr')
provides=('kicad')
+makedepends=('clang')
_github_project='kicad-source-mirror'
source=("https://github.com/KiCad/${_github_project}/archive/${_pkgver}.tar.gz")
md5sums=('8ad977a2cde8d60c793ef4cb04086dc7')
install=kicad.install
+
#prepare() {
#sed -i -e 's|boost/uuid/sha1.hpp|boost/uuid/detail/sha1.hpp|g' kicad-source-mirror-5.0.0/3d-viewer/3d_cache/3d_cache.cpp
#}
@@ -27,7 +28,7 @@ build() {
cd "${srcdir}/${_github_project}-${_pkgver}"
mkdir -p build
cd build
- cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ CXX=clang++ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DKICAD_USE_OCE=OFF \
@@ -47,5 +48,5 @@ build() {
package() {
cd "${srcdir}/${_github_project}-${_pkgver}"
cd build
- make DESTDIR="${pkgdir}" install
+ CXX=clang++ make DESTDIR="${pkgdir}" install
}