summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b974f8c66a2..7bde5e4d3873 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,47 @@
# Maintainer: ml <ml@visu.li>
pkgname=kind
pkgver=0.8.1
-pkgrel=2
+pkgrel=3
pkgdesc='Kubernetes IN Docker - local clusters for testing Kubernetes'
arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
url='https://kind.sigs.k8s.io/'
license=('Apache')
depends=('docker')
-optdepends=('podman: to use podman as container engine')
-makedepends=('go' 'git' 'gzip')
+optdepends=(
+ 'podman: to use podman as container engine'
+ 'bazel: building node images with bazel'
+)
+makedepends=('go' 'git')
optdepends=('kubectl: for managing Kubernetes clusters')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kubernetes-sigs/kind/archive/v${pkgver}.tar.gz")
+source=("https://github.com/kubernetes-sigs/kind/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
sha256sums=('2a04a6427d45fa558fc4bfe90fde0b7ea2c7f2d6fcf3b7c581fc281ae49b5447')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
go mod download
}
build() {
local _commit
- _commit="$(zcat "${pkgname}-${pkgver}.tar.gz" | git get-tar-commit-id)"
- cd "${pkgname}-${pkgver}"
+ _commit="$(bsdcat "$pkgname-$pkgver.tar.gz" | git get-tar-commit-id)"
+ cd "$pkgname-$pkgver"
+ export CGO_ENABLED=1
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
export CGO_LDFLAGS="$LDFLAGS"
- export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
- go build -o "$pkgname" -ldflags "-X sigs.k8s.io/kind/pkg/cmd/kind/version.GitCommit=${_commit}"
+ export GOFLAGS='-buildmode=pie -mod=readonly -modcacherw -trimpath'
+ go build -o "$pkgname" -ldflags "-linkmode=external -X sigs.k8s.io/kind/pkg/cmd/kind/version.GitCommit=$_commit"
}
check() {
- cd "${pkgname}-${pkgver}"
- # CGO_FLAGS might break tests for yay users. TODO: investigate
- unset CGO_CFLAGS
+ cd "$pkgname-$pkgver"
go test ./...
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 "$pkgname" "${pkgdir}/usr/bin/${pkgname}"
- ./"$pkgname" completion bash | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
- ./"$pkgname" completion zsh | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
+ ./"$pkgname" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ ./"$pkgname" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
}