summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 1 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e06bfcd4a73a..d4382322731f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <ml@visu.li>
pkgname=kind
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='Kubernetes IN Docker - local clusters for testing Kubernetes'
arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
url='https://kind.sigs.k8s.io/'
@@ -16,11 +16,6 @@ optdepends=('kubectl: for managing Kubernetes clusters')
source=("https://github.com/kubernetes-sigs/kind/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
sha256sums=('c154289659a7ef30b301a0787ecfa2e08edaada6059bf5acefe9f3be1e026381')
-prepare() {
- cd "$pkgname-$pkgver"
- go mod download
-}
-
build() {
local _commit
_commit="$(bsdcat "$pkgname-$pkgver.tar.gz" | git get-tar-commit-id)"
@@ -34,12 +29,6 @@ build() {
go build -o "$pkgname" -ldflags "-linkmode=external -X sigs.k8s.io/kind/pkg/cmd/kind/version.GitCommit=$_commit"
}
-check() {
- cd "$pkgname-$pkgver"
- # TODO avoid e2e stuff
- #go test ./...
-}
-
package() {
cd "$pkgname-$pkgver"
install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"