summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 415ee582c279..a3b31e3d3645 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: LinArcx <linarcx at gmail.com>
pkgname=kindd
pkgver=2.0.1
-pkgrel=5
-pkgdesc=" A Kindful dd gui written in qt quick"
+pkgrel=6
+pkgdesc="A Kindful dd GUI written in Qt Quick"
arch=('any')
url="https://github.com/LinArcX/Kindd"
license=('GPL3')
-depends=('polkit' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-graphicaleffects' 'qt5-svg')
+depends=('polkit' 'qt5-quickcontrols' 'qt5-quickcontrols2'
+ 'qt5-graphicaleffects' 'qt5-svg')
conflicts=("$pkgname-git")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/LinArcX/Kindd/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('5dbfcbc07cdc36a6a5d2b40ed5e8159a305ccc5608580635961ed9ad6f43e2b3')
build() {
@@ -20,9 +21,10 @@ build() {
package() {
cd "Kindd-$pkgver"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 appconf/"$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 appconf/"$pkgname.svg" "$pkgdir/usr/share/pixmaps/kindd.svg"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 appconf/"$pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 appconf/"$pkgname.svg" -t \
+ "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}