summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fe552937123..57535a5d9bef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: AUR[flyingpig]
# Contributor: Valentin-Costel Haloiu <vially.ichb@gmail.com>
# Contributor: Eugene Yunak <e.yunak@gmail.com>
# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
pkgname=kindlegen
pkgver=2.9
-pkgrel=5
-pkgdesc="A command line tool used to build eBooks that can be sold through Amazon's Kindle platform."
-arch=('i686' 'x86_64')
+pkgrel=6
+pkgdesc='cli tool to build eBooks that can be used on Amazon’s Kindle platform (binary)'
+arch=(i686 x86_64)
url="https://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000765211"
license=(custom)
-source=("https://archive.org/download/kindlegen/kindlegen")
-sha256sums=('b8b0f0ab83e74070119066bf4f3c56267e5ee43d2c2bac7091bb447e9f461a69')
+source=("https://archive.org/download/$pkgname$pkgver/${pkgname}_linux_2.6_i386_v${pkgver/./_}.tar.gz")
+md5sums=('21aef3c8846946203e178c83a37beba1')
+sha256sums=('9828db5a2c8970d487ada2caa91a3b6403210d5d183a7e3849b1b206ff042296')
package() {
- install -D -m755 $srcdir/kindlegen $pkgdir/usr/bin/kindlegen
-
+ install -Dm0755 -t "$pkgdir/usr/bin/" kindlegen
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" EULA.txt "KindleGen Legal Notices 2013-02-19 Linux.txt"
+ install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" manual.html docs/english/*
}