summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63f3cc541a6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexander Paetzelt <techge+arch [ät] posteo [do] net>
+pkgname=kismet-git
+pkgver=2017120
+pkgrel=1
+pkgdesc="Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1"
+arch=('x86_64')
+url="https://www.kismetwireless.net/"
+license=('GPL')
+depends=('libmicrohttpd' 'libelf' 'libpcap' 'libnm')
+optdepends=('hackrf: use with HackRF compatible software defined radio (SDR)')
+conflicts=('kismet')
+backup=('etc/kismet/kismet.conf' 'etc/kismet/kismet_alerts.conf' 'etc/kismet/kismet_httpd.conf' 'etc/kismet/kismet_logging.conf' 'etc/kismet/kismet_memory.conf' 'etc/kismet/kismet_storage.conf')
+install=kismet.install
+source=("https://github.com/kismetwireless/kismet/archive/master.zip")
+md5sums=('SKIP')
+
+build() {
+ cd "kismet-master"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/kismet
+ make
+}
+
+package() {
+ cd "kismet-master"
+ make DESTDIR="$pkgdir/" install
+ mkdir -p ${pkgdir}/usr/bin/kismet_capture_tools/
+ install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/kismet_capture_tools/"
+ install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/kismet_capture_tools/"
+}