summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e033d624109..74ad9d52fa82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexander Paetzelt <techge+arch [ät] posteo [do] net>
pkgname=kismet-git
-pkgver=20171209
+pkgver=20171210
pkgrel=1
pkgdesc="Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1"
arch=('x86_64')
@@ -15,16 +15,23 @@ source=("https://github.com/kismetwireless/kismet/archive/master.zip")
md5sums=('SKIP')
build() {
- cd "kismet-master"
- ./configure --prefix=/usr \
+ cd "kismet-master"
+ ./configure --prefix=/usr \
--sysconfdir=/etc/kismet
- make
+ make
}
package() {
- cd "kismet-master"
- make DESTDIR="$pkgdir/" install
+ cd "kismet-master"
+ make DESTDIR="$pkgdir/" install
+
+ # install capture_tools setuid so that kismet can started as user and still
+ # network device can get handled by capture tools
mkdir -p ${pkgdir}/usr/bin/kismet_capture_tools/
install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/kismet_capture_tools/"
install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/kismet_capture_tools/"
+
+ # include new docs in /usr/share/doc/
+ mkdir -p ${pkgdir}/usr/share/doc/$pkgname/
+ install -Dm 644 docs/dev/* "$pkgdir/usr/share/doc/$pkgname/"
}