summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74ad9d52fa82..44ef3575e171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Alexander Paetzelt <techge+arch [ät] posteo [do] net>
pkgname=kismet-git
-pkgver=20171210
+pkgver=20180318
pkgrel=1
pkgdesc="Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1"
arch=('x86_64')
url="https://www.kismetwireless.net/"
license=('GPL')
-depends=('libmicrohttpd' 'libelf' 'libpcap' 'libnm')
+depends=('libmicrohttpd' 'libelf' 'libpcap' 'libnm' 'protobuf' 'protobuf-c')
optdepends=('hackrf: use with HackRF compatible software defined radio (SDR)')
conflicts=('kismet')
backup=('etc/kismet/kismet.conf' 'etc/kismet/kismet_alerts.conf' 'etc/kismet/kismet_httpd.conf' 'etc/kismet/kismet_logging.conf' 'etc/kismet/kismet_memory.conf' 'etc/kismet/kismet_storage.conf')
@@ -24,14 +24,17 @@ build() {
package() {
cd "kismet-master"
make DESTDIR="$pkgdir/" install
-
- # install capture_tools setuid so that kismet can started as user and still
+
+ # install capture_tools setuid so that kismet can started as user and
# network device can get handled by capture tools
- mkdir -p ${pkgdir}/usr/bin/kismet_capture_tools/
- install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/kismet_capture_tools/"
- install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/kismet_capture_tools/"
+ install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/"
+ install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/"
# include new docs in /usr/share/doc/
mkdir -p ${pkgdir}/usr/share/doc/$pkgname/
install -Dm 644 docs/dev/* "$pkgdir/usr/share/doc/$pkgname/"
+
+ # create group kismet via sysusers
+ cd ../..
+ install -vDm 644 "${pkgname}-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
}