summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0bd5541baa3d..b9fedc4ad37b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=kmon-bin
-pkgver=1.6.0
+pkgver=1.6.2
pkgrel=1
pkgdesc="Linux kernel manager and activity monitor"
arch=('x86_64')
@@ -12,7 +12,7 @@ depends=('gcc-libs' 'libxcb')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}")
source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}-$pkgver-x86_64-unknown-linux-gnu.tar.gz"{,.sig})
-sha512sums_x86_64=('fdbe55c9f382c3601a98a410ae36161388af39829c93eb2ba08988d8f5106695df93b6c7d2293069fa19eec63066d73355d0ab591eb0abfc0d10c815d55975cb'
+sha512sums_x86_64=('b01b52e2e54663cbdaee12dbf475a6f309c9e0f8f855cbc382aa5825277fc99de38f3261d08a8ac5d5e6c3eea207b9ec4715cc897c0dca929f18ab2e6076132a'
'SKIP')
validpgpkeys=('C4B2D24CF87CD188C79D00BB485B7C52E9EC0DC6') # kmon releases <kmonlinux@protonmail.com>
@@ -21,4 +21,7 @@ package() {
install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 "man/${pkgname%-bin}.8" -t "$pkgdir/usr/share/man/man8"
+ install -Dm 644 "completions/${pkgname%-bin}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-bin}"
+ install -Dm 644 "completions/${pkgname%-bin}.fish" -t "${pkgdir}/usr/share/fish/vendor_completions.d"
+ install -Dm 644 "completions/_${pkgname%-bin}" -t "${pkgdir}/usr/share/zsh/site-functions"
}