summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5ffd6d50898..bf77c9f66334 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=knemo
pkgver=0.7.7.git20151003
-pkgrel=6
+pkgrel=7
pkgdesc="The KDE Network Monitor"
arch=('x86_64')
url="https://www.linux-apps.com/content/show.php?content=12956"
@@ -15,14 +15,13 @@ license=('GPL')
depends=('kdelibs4support' 'libksysguard' 'knotifyconfig' 'wireless_tools' 'iw' 'plasma-framework' 'hicolor-icon-theme')
makedepends=('extra-cmake-modules' 'kcmutils' 'plasma-framework' 'kdoctools' 'git' 'kdesignerplugin' 'kinit')
options=('libtool')
-#source=(https://kde-apps.org/CONTENT/content-files/12956-${pkgname}-${pkgver}.tar.xz)
_commit=f3afe2e4b6f091f21a64905965abafd2ef46826d # frameworks
-source=("git://git.kde.org/knemo.git#commit=$_commit" knemo-gcc6.patch)
+source=("git+https://github.com/KDE/knemo.git#commit=$_commit" 'knemo-gcc6.patch')
sha256sums=('SKIP'
'840fe4f68ff6b9e801d98482a0b76f42764332d81071589ac3bc5632bfc49d92')
prepare() {
- mkdir build
+ mkdir -p build
cd knemo
# Fix build with GCC 6
@@ -37,7 +36,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
- make -j$(($(nproc) + 1))
+ make
}
package() {