summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 218525ef551d..ca6001348fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ pkgdesc='Abstraction for system notifications'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(libcanberra libdbusmenu-qt5 kwindowsystem-git kconfig-git kcoreaddons-git qt5-speech libxtst)
-makedepends=(git extra-cmake-modules-git qt5-tools doxygen)
+depends=(libcanberra libdbusmenu-qt6 kwindowsystem-git kconfig-git kcoreaddons-git qt6-speech libxtst)
+makedepends=(git extra-cmake-modules-git qt6-tools doxygen)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-groups=(kf5-git)
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}