summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 21 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07ddd8b280dd..fc378c37b4cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,31 @@
# Contributor: Michael Lass <bevan@bi-co.net>
pkgname=kodi-addon-pvr-mythtv-git
-pkgver=r434.95b43c0
+pkgver=r532.84b0b6b
pkgrel=1
-_branch=Isengard
+if [ -z "$API" ]; then
+ error "No API Version Defined. 15 = Isengard, 16 = Jarvis, 99 = git master"
+ exit 1
+fi
+
+_branch=$(
+ case "${API}" in
+ 15) echo "Isengard";;
+ 16) echo "Jarvis";;
+ 99) echo "master";;
+ *) error "Unknown API version.";;
+ esac
+)
pkgdesc='MythTV PVR client addon for Kodi'
arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/kodi-pvr/pvr.hts"
license=('GPL')
makedepends=('cmake' 'git' 'kodi-platform-git')
-depends=('kodi>=15.0')
+if [ "$API" -eq "99" ]; then
+ depends=("kodi-git")
+else
+ depends=("kodi>=$API.0" "kodi<$[$API+1].0")
+fi
provides=('kodi-addon-pvr-mythtv')
conflicts=('kodi-addon-pvr-mythtv' 'kodi-pvr-addons')
source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.mythtv.git#branch=${_branch}")
@@ -22,6 +38,8 @@ pkgver() {
}
build() {
+ echo "API Version $API"
+ echo "Branch version $_branch"
mkdir -p "$pkgname/build"
cd "$pkgname/build"