summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 24 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43ae3d067247..c5ce271346f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
-# Maintainer: graysky <graysky AT archlinux DOT us>
+# Maintainer: graysky <therealgraysky AT protonmail DOT com>
-pkgbase=kodi-standalone-service
-pkgname=(kodi-standalone-service kodi-standalone-gbm-service)
-pkgver=1.95
-pkgrel=4
-pkgdesc="Systemd service to run kodi in stand-alone mode without a DE"
-# Do NOT attempt to use this package on Arch ARM! This is only for x86_64.
-# You have been warned.
-arch=('x86_64')
+pkgname=kodi-standalone-service
+pkgver=1.137
+pkgrel=1
+pkgdesc="Systemd services to run kodi in stand-alone mode without a DE"
+# This is only for x86_64
+# The kodi-rpi packages for ArchARM provide their own versions of this package
+arch=(x86_64)
url="https://github.com/graysky2/kodi-standalone-service"
-license=('GPL')
+license=(MIT)
install=readme.install
-source=("https://github.com/graysky2/$pkgbase/archive/v$pkgver.tar.gz")
-sha256sums=('da49c9f1cf6dad28ca88904db1d8b676cd935781a58f7c7917523e28a5bf74c8')
+depends=(polkit kodi)
+replaces=(kodi-standalone-x11-service kodi-standalone-gbm-service kodi-standalone-wayland-service)
+backup=(etc/conf.d/kodi-standalone)
+optdepends=(
+ 'cage: for kodi-wayland.service'
+ 'xorg-server: for kodi-x11.service'
+ 'xorg-xinit: for kodi-x11.service'
+ 'xorg-xwayland: for kodi-wayland.service'
+)
+source=("$pkgname-v$pkgver.tar.gz::https://github.com/graysky2/$pkgname/archive/v$pkgver.tar.gz")
+b2sums=('7ba4612bd089103b78bdf04838f150c2be023b7ccd9814b9d5d3b2d37a266e0db2a1cbc378254a5ba2c98de5f58193b0acf22c5ac104f91f1c9b614624177610')
-package_kodi-standalone-service() {
- depends=('kodi' 'polkit' 'xorg-server' 'xorg-xinit')
- install -Dm644 "$srcdir/$pkgbase-$pkgver/init/kodi.service" \
- "$pkgdir/usr/lib/systemd/system/kodi.service"
- install -dm 700 "$pkgdir"/var/lib/kodi
- chown 420:420 "$pkgdir"/var/lib/kodi
-}
-
-package_kodi-standalone-gbm-service() {
- depends=('kodi-gbm' 'polkit' 'libinput')
- install -Dm644 "$srcdir/$pkgbase-$pkgver/init/kodi-gbm.service" \
- "$pkgdir/usr/lib/systemd/system/kodi-gbm.service"
- install -dm 700 "$pkgdir"/var/lib/kodi
- chown 420:420 "$pkgdir"/var/lib/kodi
+package() {
+ cd "$pkgname-$pkgver"
+ make
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: