summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b266dd9e92db..b8ec36beaeca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Thor M. K. Høgås <thor alfakrøll roht dott no>
+# Maintainer : Thor M. K. Høgås <thor alfakrøll roht dott no>
pkgname=koku-xinput-wine-git
-pkgver=1.2.1.r0.g11e7f4a
+pkgver=1.2.3.r0.gd976325
pkgrel=1
_srcname=koku-xinput-wine
pkgdesc="Adds xinput support to Wine without modifying the source binaries of Wine."
arch=('i686' 'x86_64')
url="https://www.github.com/KoKuToru/koku-xinput-wine"
-license=('custom:BSD2')
+license=('BSD')
provides=("${pkgname[0]%-git}")
conflicts=("${pkgname[0]%-git}")
@@ -20,22 +20,24 @@ md5sums=('SKIP')
pkgver() {
- cd "${_srcname}"
+ cd "${_srcname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${_srcname}"
- cmake .
- make
+ cmake -DCMAKE_BUILD_TYPE=Release .
+ make
}
package() {
cd "${srcdir}/${_srcname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/BSD2"
+
if [ "$CARCH" == "x86_64" ]; then
install -Dm755 koku-xinput-wine.so koku-xinput-wine64.so -t "${pkgdir}/usr/lib32/"
else
+ warning "i686 is not supported, although it may work, in this package."
install -Dm755 koku-xinput-wine.so -t "${pkgdir}/usr/lib/"
fi
}