summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 811cb6837ae7..30c3d63256de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=komanda-cli-git
-pkgver=v0.9.4.r29.gb5ba03b
+pkgver=0.9.4.r32.g8596023
pkgrel=1
pkgdesc='The Komanda Command-line IRC Client'
arch=(x86_64)
url='https://github.com/mephux/komanda-cli'
license=(BSD)
-makedepends=(go dep)
-source=("${pkgname}::git+https://github.com/mephux/komanda-cli.git")
-sha256sums=('SKIP')
+makedepends=(go git dep)
+source=("${pkgname}::git+https://github.com/mephux/komanda-cli.git"
+ "runtime-fix.patch")
+sha256sums=('SKIP'
+ '1ff96e713c35aed197ba11d4681836b53016b1a83ea950c20cbaaaf2c122a560')
pkgver() {
cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
prepare() {
cd "${srcdir}/${pkgname}"
+ patch -p1 -i '../runtime-fix.patch'
+
install -m755 -d "${srcdir}/go/src/github.com/mephux/"
cp -a "${srcdir}/${pkgname}" "${srcdir}/go/src/github.com/mephux/komanda-cli"
}