summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c0a8db075b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Simon Weald <simon[at]simonweald[dot]com>
+
+pkgname=kompose
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Takes a Docker Compose file and translates it into Kubernetes resources"
+url="http://kompose.io/"
+license=('Apache')
+arch=('x86_64')
+[ "$CARCH" = 'x86_64' ] && _arch='linux-amd64'
+
+source_x86_64=("https://github.com/kubernetes-incubator/kompose/releases/download/v$pkgver/kompose-linux-amd64")
+md5sums_x86_64=('a4039136b79c2073177e5d9d2ca12516')
+
+package() {
+ install -Dm755 "$srcdir/$pkgname-$_arch" "$pkgdir/usr/bin/$pkgname"
+}