summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bfa03dbeae2..848a8a0e6b24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,9 +26,17 @@ package(){
install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
- mkdir usr/bin 2> /dev/null; mv opt/bin/* usr/bin; rm -rf opt/bin
- rsync -a opt/* usr; rm -rf opt
+ # Fix openresty location
+ cd usr/local/bin/
+ sed "s:usr/local:opt:" kong > kongs
+ rm kong
+ mv kongs kong
+ cd "${pkgdir}"
+
+ mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+
+ rsync -a usr/local/* usr; rm -rf usr/local
cd ..