summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 22 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3a2a5cfe186..92ece07a2882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,35 +8,35 @@ arch=('any')
url="https://getkong.org"
license=('Apache')
groups=('')
-depends=('libyaml' 'lua51' 'luajit' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync')
+depends=('libyaml' 'lua51' 'luajit' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync' 'wget')
options=('!strip' '!emptydirs')
install=${pkgname}.install
-# source=("https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb")
-# sha512sums=('755e7b1b2cfae427c1dc49ef5bd0dff72b06fda690438f2b831762268313ce53aa14d3f42d2b8f13f6c3cb3643ef1aa74ffde7ccac14b80dd3fc527d3be5204b')
+source=("https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb")
+sha512sums=('755e7b1b2cfae427c1dc49ef5bd0dff72b06fda690438f2b831762268313ce53aa14d3f42d2b8f13f6c3cb3643ef1aa74ffde7ccac14b80dd3fc527d3be5204b')
-# package(){
+package(){
-# # Extract package data
-# tar xzf data.tar.gz -C "${pkgdir}"
+ # Extract package data
+ tar xzf data.tar.gz -C "${pkgdir}"
-# # Fix directories structure differences
-# cd "${pkgdir}"
-# install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-# install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+ # Fix directories structure differences
+ cd "${pkgdir}"
+ install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
-# # # Fix openresty location
-# cd usr/local/bin/
-# sed -i "s+usr/local/openresty+opt/openresty+g" kong
-# sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
-# sed -i "s+usr/local/openresty+opt/openresty+g" lapis
-# sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
-# rm luarocks luarocks-5.1 luarocks-admin luarocks-admin-5.1
-# cd "${pkgdir}"
+ # # Fix openresty location
+ cd usr/local/bin/
+ sed -i "s+usr/local/openresty+opt/openresty+g" kong
+ sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
+ sed -i "s+usr/local/openresty+opt/openresty+g" lapis
+ sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
+ rm luarocks luarocks-5.1 luarocks-admin luarocks-admin-5.1
+ cd "${pkgdir}"
-# mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+ mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
-# rsync -a usr/local/* usr; rm -rf usr/local
+ rsync -a usr/local/* usr; rm -rf usr/local
-# cd ..
+ cd ..
-# }
+}