summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bcb13be54cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: DDoSolitary <DDoSolitary@gmail.com>
+pkgname=konsole-tomorrow-theme-git
+pkgver=r1.6f43a05
+pkgrel=1
+arch=(any)
+url=https://github.com/dram/konsole-tomorrow-theme
+license=(MIT)
+source=($pkgname::git+https://github.com/dram/konsole-tomorrow-theme)
+md5sums=(SKIP)
+depends=(konsole)
+makedepends=(git)
+conficts=(konsole-tomorrow-theme)
+provides=(konsole-tomorrow-theme)
+
+pkgver() {
+ cd $pkgname
+ printf r%s.%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+package() {
+ cd $pkgname
+ for i in *.colorscheme; do
+ install -Dm644 "$i" "$pkgdir/usr/share/konsole/$i"
+ done
+}