summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dbe78142aa1..d3a285035c30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Rodriguez <dissonant.tech@gmail.com>
pkgname=kops-git
-pkgver=1.17.0.beta.1.r0.g32af4ed9b
+pkgver=1.25.0.alpha.2.r85.g429ebecdca
pkgrel=1
pkgdesc="Kubernetes Operations (kops) - Production Grade K8s Installation, Upgrades, and Management. (git version)"
arch=('x86_64')
@@ -10,9 +10,14 @@ license=('Apache')
makedepends=('go' 'git')
provides=('kops')
conflicts=('kops' 'kops-bin')
-source=("${pkgname}-${pkgver}::git+https://github.com/kubernetes/kops")
+source=("${pkgname}::git+https://github.com/kubernetes/kops")
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare(){
export GOPATH=$srcdir
mkdir -p "$GOPATH/src/k8s.io"