summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f530d93ff0f3..fa0893d869e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Giusy Margarita <kurmikon at libero dot it>
pkgname=korla-icon-theme
-pkgver=1.0.3
-pkgrel=3
+pkgver=1.0.4
+pkgrel=1
pkgdesc="Korla icon theme suitable for every desktop environment, dark and light versions"
arch=("any")
url="https://github.com/bikass/korla"
@@ -14,11 +14,20 @@ optdepends=(
"gnome-icon-theme: fallback Gnome icon theme")
install="$pkgname.install"
source=("https://github.com/bikass/korla/archive/v$pkgver.tar.gz")
-md5sums=("a52a1b62ed2dbed2223ea0ec41a97370")
+md5sums=("0f4b5a01d225ed30cef90e44d51ae374")
_iconpath=usr/share/icons
+_iconcache=icon-theme.cache
package() {
+ cd "$srcdir/korla-$pkgver"
+
+ # Delete useless files from source folder
+ rm -f "korla/create-new-icon-theme.cache.sh"
+ rm -f "korla/$_iconcache"
+ rm -f "korla-light/create-new-icon-theme.cache.sh"
+ rm -f "korla-light/$_iconcache"
+
install -dm755 "$pkgdir/$_iconpath"
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
@@ -27,16 +36,16 @@ package() {
# the theme locally and he messed with modes in the past making some icons unreadable
# and some directories not executable if installed system wide while he didn't notice
# any issue because he installed the theme under the local icon folder on his system.
- cd "$srcdir/korla-$pkgver"
cp -dr --no-preserve=mode "korla" "$pkgdir/$_iconpath/korla"
cp -dr --no-preserve=mode "korla-light" "$pkgdir/$_iconpath/korla-light"
- install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -Dm644 "korla/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Create empty icon cache files, they will be filled during post_install and
+ # post_upgrade scripts
+ touch -a "$pkgdir/$_iconpath/korla/$_iconcache"
+ touch -a "$pkgdir/$_iconpath/korla-light/$_iconcache"
- cd "$pkgdir/$_iconpath"
- rm -f "korla/create-new-icon-theme.cache.sh"
- rm -f "korla-light/create-new-icon-theme.cache.sh"
- rm -f "korla/LICENSE"
- rm -f "korla-light/LICENSE"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "im1.png" "$pkgdir/usr/share/doc/$pkgname/im1.png"
+ install -Dm644 "im2.png" "$pkgdir/usr/share/doc/$pkgname/im2.png"
}