aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 53 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41b65e10e4ca..1f1a7bacb9d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,74 @@
-# Maintainer: Frantic1048 <Archer@frantic1048.com>
+# Maintainer: Frantic1048 <archer@frantic1048.com>
pkgname=kreogist-mu
-pkgver='0.9.2'
+pkgver='0.9.9.1'
pkgrel=1
epoch=1
pkgdesc="Fantastic cross-platform music manager.based on Qt5"
-changelog="kreogist-mu.changelog"
arch=('x86_64')
url="https://kreogist.github.io/Mu/"
license=('GPL')
+changelog="$pkgname.changelog"
+install="$pkgname.install"
depends=(
- 'qt5-base'
'pulseaudio'
'ffmpeg'
'phonon-qt5'
'gst-libav'
- 'gstreamer0.10-ffmpeg')
+ 'gstreamer0.10-ffmpeg'
+ 'desktop-file-utils'
+ 'hicolor-icon-theme'
+)
+
optdepends=(
'gst-plugins-good: good plugin libraries'
'gst-plugins-bad: bad plugin libraries'
'gst-plugins-ugly: ugly plugin libraries'
)
-changelog=$pkgname.changelog
-source=("https://github.com/frantic1048/mu-archlinux/releases/download/$pkgver/$pkgname-$pkgver-$arch.7z")
-md5sums=('abbe752b7e9a608cbe52933267fefba7')
+
+makedepends=(
+ 'git'
+ 'gcc'
+ 'qt5-tools'
+)
+
+source=(
+ "https://github.com/Kreogist/mu-archlinux/releases/download/$pkgver.$pkgrel/$pkgname-resource.tar.gz"
+ "https://codeload.github.com/Kreogist/Mu/tar.gz/$pkgver"
+)
+
+sha224sums=(
+ '1f0247a0f08cffc062f80ca68fa5e24c64c16d559aade32524d66cc3'
+ '2a9d7ee064b5d8623691a0bcd0047ae876e7aaaab77bdfad4e9e23fe'
+)
+
+build() {
+ mkdir -p $srcdir/Mu-build
+ cd $srcdir/Mu-build
+ qmake "CONFIG+=release" $srcdir/Mu-$pkgver/mu.pro
+ make
+}
package() {
- cd "$pkgname-$pkgver-$arch"
- install -d "${pkgdir}/usr/bin/"
- install -m=775 $pkgname "${pkgdir}/usr/bin"
- install -d "${pkgdir}/usr/share/icons/hicolor/512x512/apps/"
- install -m=664 $pkgname.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/"
- install -d "${pkgdir}/usr/share/applications/"
- install -m=664 $pkgname.desktop "${pkgdir}/usr/share/applications/"
+ # excecutable
+ mv $srcdir/Mu-build/bin/mu $srcdir/Mu-build/bin/kreogist-mu
+ install -d $pkgdir/usr/bin/
+ install -m775 $srcdir/Mu-build/bin/kreogist-mu $pkgdir/usr/bin/
+
+ # i18n files
+ # https://github.com/Kreogist/Mu/issues/17#issuecomment-164236195
+ install -d $pkgdir/usr/share/Kreogist/mu/Language/
+ for f in $srcdir/Mu-build/bin/*.qm
+ do
+ baseName=$(basename $f)
+ languageName="${baseName%.qm}"
+ install -d $pkgdir/usr/share/Kreogist/mu/Language/$languageName/
+ install -m664 $f $pkgdir/usr/share/Kreogist/mu/Language/$languageName/
+ done
+
+ # static resource
+ install -d $pkgdir/usr/share/icons/hicolor/512x512/apps/
+ install -m664 $srcdir/$pkgname-resource/$pkgname.png $pkgdir/usr/share/icons/hicolor/512x512/apps/
+ install -d $pkgdir/usr/share/applications/
+ install -m664 $srcdir/$pkgname-resource/$pkgname.desktop $pkgdir/usr/share/applications/
}