summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd914309f172
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+
+pkgname=krill-git
+pkgver=v0.3.0.r1.ga1031ea
+pkgrel=1
+pkgdesc="Read and filter web feeds."
+arch=('any')
+url="https://github.com/p-e-w/krill"
+license=('GPL3')
+depends=('python-beautifulsoup4' 'python-blessings' 'python-feedparser' 'python-requests')
+makedepends=('git' 'python-setuptools')
+provides=('krill')
+conflicts=('krill')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd krill
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd krill
+ python setup.py build
+}
+
+package() {
+ cd krill
+ python setup.py install --root="$pkgdir/" --optimize=1
+}