summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20e6c7ea82a2..d26471bd396d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname=kronosnet-git
_pkgname=kronosnet
-pkgver=1.90.r231.gef4c981
+pkgver=1.23.r2.gbf929fc3
pkgrel=1
pkgdesc="VPNs on steroids"
arch=('i686' 'x86_64')
url="http://www.kronosnet.org/"
license=('GPL2')
makedepends=('git' 'doxygen' 'lksctp-tools' 'libqb-git')
-depends=('nss' 'lzo')
+depends=('nss' 'lzo' 'zstd' 'bzip2' 'libnl')
provides=($_pkgname)
conflicts=($_pkgname)
-source=("$pkgname::git+https://github.com/fabbione/$_pkgname.git")
+source=("$pkgname::git+https://github.com/$_pkgname/$_pkgname.git#branch=stable1-proposed")
md5sums=('SKIP')
pkgver() {
@@ -33,6 +33,8 @@ build() {
--sbindir=/usr/bin \
--enable-publicandocs \
--with-systemddir=/usr/lib/systemd/system
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
make V=0
}