summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ec565580a74..38965ed6de62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=krop
pkgver=0.6.0
-pkgrel=3
+pkgrel=4
pkgdesc="A tool to crop PDF files, with an eye towards eReaders."
arch=('any')
url="http://arminstraub.com/computer/krop"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('python' 'python-pypdf2' 'python-pyqt5' 'python-pyqt5-sip' 'python-poppler-qt5')
-makedepends=('sip')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'sip')
source=("$pkgname-$pkgver.tar.gz::https://github.com/arminstraub/krop/archive/v${pkgver}.tar.gz")
sha256sums=('97022416ec4f2ff70e0ab38d3f3aaff83a68dca99f3e273c29e9f3dd72bf88d9')
@@ -21,6 +21,7 @@ package() {
cd $pkgname-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/krop/LICENSE"
}