summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dea3438d3fd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Max Reitz <xanclic at xanclic dot moe>
+pkgname=krunner-mpd-git
+pkgver=r32.96f8e44
+pkgrel=1
+pkgdesc="KRunner plugin to control an MPD server"
+arch=('any')
+url="https://github.com/XanClic/krunner-mpd"
+license=('GPL3')
+depends=('dbus'
+ 'plasma-workspace'
+ 'ruby'
+ 'ruby-dbus'
+ 'ruby-i18n'
+ 'ruby-locale'
+ 'ruby-ruby-mpd')
+makedepends=('coreutils'
+ 'kdelibs4support'
+ 'make')
+provides=('krunner-mpd')
+conflicts=('krunner-mpd')
+install=$pkgname.install
+source=("$pkgname::git://github.com/XanClic/krunner-mpd.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ ./configure --prefix=/usr --skip-bundle-install
+ make
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}