summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5c1e4d3ad18..226b01081d09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Merged with official ABS kscreenlocker PKGBUILD by João, 2021/04/20 (all respective contributors apply herein)
-# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Marcin Mikołajczak <me@mkljczk.pl>
pkgname=kscreenlocker-git
-pkgver=5.21.80_r832.gd610b79
-pkgrel=1
+pkgver=6.0.80_r1288.g2c17bd6
+pkgrel=2
pkgdesc='Library and components for secure lock screen architecture'
arch=($CARCH)
url='https://kde.org/plasma-desktop/'
-license=(LGPL)
+license=(LGPL-2.0-or-later)
+depends=(gcc-libs glibc kconfig-git kcoreaddons-git kcrash-git kdeclarative-git kglobalaccel-git ki18n-git kidletime-git kio-git kirigami-git knotifications-git kpackage-git ksvg-git kwindowsystem-git kxmlgui-git layer-shell-qt-git libkscreen-git libx11 libxcb libxi pam libplasma-git qt6-base qt6-declarative wayland xcb-util-keysyms)
+makedepends=(git extra-cmake-modules-git kcmutils-git kdoctools-git)
+optdepends=('kcmutils: configuration module')
groups=(plasma-git)
-depends=(kidletime-git kwayland-git kdeclarative-git perl layer-shell-qt-git)
-makedepends=(git extra-cmake-modules-git kdoctools-git kcmutils-git libxcursor)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-optdepends=('kcmutils-git: configuration module')
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
@@ -27,6 +27,7 @@ pkgver() {
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
-DBUILD_TESTING=OFF
cmake --build build