summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0202b1e0946..5aa3660d83f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,23 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=ktextwidgets-git
-pkgver=5.240.0_r506.gc9d0cae
+pkgver=5.240.0_r508.g00796e7
pkgrel=1
pkgdesc='Advanced text editing widgets'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(kcompletion-git kconfigwidgets-git sonnet-git qt5-speech)
-makedepends=(git extra-cmake-modules-git doxygen qt5-tools)
+depends=(kcompletion-git kconfigwidgets-git sonnet-git qt6-speech)
+makedepends=(git extra-cmake-modules-git doxygen qt6-tools)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-groups=(kf5-git)
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}