summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..497e3cf2f740
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Brad Erhart <brae dot 04 plus aur at gmail dot com>
+
+pkgname=kubectl-preflight-bin
+_pkgname="${pkgname%-bin}"
+_pkgname2="${_pkgname#kubectl-}"
+pkgver=0.10.5
+pkgrel=1
+pkgdesc='Kubectl plugin for pre-installation cluster conformance testing and validation (preflight checks)'
+arch=('x86_64')
+_goos='linux'
+_goarch='amd64'
+url="https://troubleshoot.sh"
+license=('Apache')
+depends=('kubectl')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("${_pkgname2}_${pkgver}_${_goos}_${_goarch}.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v$pkgver/${_pkgname2}_${_goos}_${_goarch}.tar.gz")
+sha256sums=(9b11f6ee5536a9c6928e88b73a7884268d56c06459e768610e7d2be5cad58948)
+
+package() {
+ install -Dm 755 "${_pkgname2}" "$pkgdir/usr/bin/${_pkgname}"
+}